Config pppoe Soho77

Configurazioni per connettività ADSL, ISDN e switch per privati e piccole network

Moderators: Federico.Lagni, TheIrish, Wizard, andrewp

Config pppoe Soho77

Postby borgorosso » Wed 08 Nov , 2017 9:51 am

Ho letto in giro che per far funzionare il pppoe sul Soho77, devo abilitare il vpdn
Dovrei quindi aggiungere tali righe nella configurazione

vpdn enable
!
vpdn-group ppoe
request-dialin
protocol pppoe

Provo da Hyper terminal a dare il comando enable vpdn per abilitarlo, ma non è corretto in quanto mi da errore sulla lettera p di vpdn
Il comando per abilitare vpdn io lo do entrando con ena, poi password e enable vpdn, sbaglio qualcosa?
Che comandi devo eseguire da hyper terminal?
Ovviamente ho già configurato la parte interface ATM0 che risulta ora essere così

Code: Select all
interface ATM0
 no ip address
 no ip mroute-cache
 no atm ilmi-keepalive
 dsl operating-mode auto
 pvc 8/35
  pppoe-client dial-pool-number 1

Quindi attualmente la configurazione è la seguente e non funziona in pppoe
Code: Select all
Building configuration...

Current configuration : 2425 bytes
!
version 12.3
no service pad
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
service password-encryption
!
hostname gw-daniele
!
boot-start-marker
boot-end-marker
!
logging buffered 32768 informational
no logging console
no logging monitor
enable secret 5 $1$Og.2$PTsNhQSSmymJR95oto8KU/
!
clock timezone UTC+1 1
clock summer-time UTC+2 recurring last Sun Mar 2:00 last Sun Oct 3:00
ip subnet-zero
ip dhcp excluded-address 192.168.1.1 192.168.1.100
ip dhcp excluded-address 192.168.1.120 192.168.1.254
!
ip dhcp pool local
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
   dns-server 85.37.17.56 85.38.28.98
!
username daniele secret 5 $1$Voga$OadEUk7ZUYI48bhG8GADr1
!
!
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip tcp adjust-mss 1452
 no ip mroute-cache
 hold-queue 100 out
!
interface ATM0
 no ip address
 no ip mroute-cache
 no atm ilmi-keepalive
 dsl operating-mode auto
 pvc 8/35
  pppoe-client dial-pool-number 1
 !
!
interface Dialer1
 ip address negotiated
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip mtu 1492
 ip nat outside
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication pap chap callin
 ppp chap hostname aliceadsl
 ppp pap sent-username aliceadsl password 7 094D42001A0016161800
!
ip nat inside source list 102 interface Dialer1 overload
ip nat inside source static udp 192.168.1.2 18969 interface Dialer1 18969
ip nat inside source static tcp 192.168.1.7 11183 interface Dialer1 11183
ip nat inside source static udp 192.168.1.7 11193 interface Dialer1 11193
ip nat inside source static tcp 192.168.1.65 16346 interface Dialer1 16346
ip nat inside source static udp 192.168.1.65 16357 interface Dialer1 16357
ip nat inside source static udp 192.168.1.250 500 interface Dialer1 500
ip nat inside source static udp 192.168.1.250 1701 interface Dialer1 1701
ip nat inside source static udp 192.168.1.250 4500 interface Dialer1 4500
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 10.0.0.0 255.255.255.0 192.168.1.2
no ip http server
!
no logging trap
access-list 23 permit 192.168.1.0 0.0.0.255
access-list 102 permit ip 192.168.1.0 0.0.0.255 any
dialer-list 1 protocol ip permit
no cdp run
banner motd ^C

------------------------------------------
           PRIVATE ADSL ROUTER

    Unauthorized access is prohibited
 Ogni accesso non autorizzato e' proibito
------------------------------------------

^C
!
line con 0
 transport output all
 stopbits 1
line vty 0 4
 login local
 transport input telnet
 transport output all
!
scheduler max-task-time 5000
end

Mi potreste indicare la procedura esatta?
Grazie
borgorosso
Cisco fan
 
Posts: 29
Joined: Wed 04 Jan , 2017 9:39 am

Re: Config pppoe Soho77

Postby borgorosso » Thu 09 Nov , 2017 6:42 am

Posto la mia configurazione funzionante per Alice 10 mb pppoe se può servire a qualcuno

Code: Select all
Building configuration...

Current configuration : 2646 bytes
!
version 12.3
no service pad
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
service password-encryption
!
hostname gw-roberto
!
boot-start-marker
boot-end-marker
!
logging buffered 32768 informational
no logging console
no logging monitor
enable secret 5 $1$Og.2$PTsNhQSSmymJR95oto8KU/
!
clock timezone UTC+1 1
clock summer-time UTC+2 recurring last Sun Mar 2:00 last Sun Oct 3:00
ip subnet-zero
ip dhcp excluded-address 192.168.1.1 192.168.1.100
ip dhcp excluded-address 192.168.1.120 192.168.1.254
!
ip dhcp pool local
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
   dns-server 85.37.17.56 85.38.28.98
!
username roberto secret 5 $1$Voga$OadEUk7ZUYI48bhG8GADr1
!
!
!
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip tcp adjust-mss 1452
 no ip mroute-cache
 hold-queue 100 out
!
interface ATM0
 no ip address
 no ip mroute-cache
 no atm ilmi-keepalive
 dsl operating-mode auto
 pvc 8/35
  pppoe-client dial-pool-number 1
 !
!
interface Dialer1
 ip address negotiated
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip mtu 1492
 ip nat outside
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication pap chap callin
 ppp chap hostname aliceadsl
 ppp pap sent-username aliceadsl password 7 094D42001A0016161800
!
ip nat inside source list 102 interface Dialer1 overload
ip nat inside source static udp 192.168.1.250 4500 interface Dialer1 4500
ip nat inside source static udp 192.168.1.250 1701 interface Dialer1 1701
ip nat inside source static udp 192.168.1.250 500 interface Dialer1 500
ip nat inside source static udp 192.168.1.2 18969 interface Dialer1 18969
ip nat inside source static tcp 192.168.1.7 11183 interface Dialer1 11183
ip nat inside source static udp 192.168.1.7 11193 interface Dialer1 11193
ip nat inside source static tcp 192.168.1.65 16346 interface Dialer1 16346
ip nat inside source static udp 192.168.1.65 16357 interface Dialer1 16357
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 10.0.0.0 255.255.255.0 192.168.1.2
no ip http server
!
no logging trap
access-list 23 permit 192.168.1.0 0.0.0.255
access-list 102 permit ip 192.168.1.0 0.0.0.255 any
dialer-list 1 protocol ip permit
no cdp run
banner motd ^CC

------------------------------------------
           PRIVATE ADSL ROUTER

    Unauthorized access is prohibited
 Ogni accesso non autorizzato e' proibito
------------------------------------------

^C
!
line con 0
 transport output all
 stopbits 1
line vty 0 4
 login local
 transport input telnet
 transport output all
!
scheduler max-task-time 5000
end
borgorosso
Cisco fan
 
Posts: 29
Joined: Wed 04 Jan , 2017 9:39 am


Return to Configurazioni End User

Who is online

Users browsing this forum: No registered users and 2 guests