QOS dentro un tunnel gre

Tutto quello che ha a che fare con le infrastrutture (non le configurazioni)

Moderators: Federico.Lagni, TheIrish, Wizard

QOS dentro un tunnel gre

Postby davide0522 » Thu 18 May , 2017 6:27 pm

Salve a tutti, pongo una domanda relativa a quality of service da applicarsi all'interno di un tunnel gre.

Scenario

Router 1
LAN 192.168.1.0 /24
Wan 88.88.88.88/30
Tunnel 1 source 88.88.88.88 - destination 99.99.99.99 - ip address 1.1.1.1/30

Router 2
LAN 192.168.2.0 /24
Wan 99.99.99.99 /30
Tunnel 1 source 99.99.99.99 - destination 88.88.88.88 - ip address 1.1.1.2/30

Con ovviamente le opportune route

Le reti si parlano regolarmente e la 192.168.1.0/24 raggiunge la 192.168.2.0/ e viceversa
Non vi sono regole di nessun tipo
Il collegamento avviene su wan, quindi con una certe "ristrettezza" di banda che spesso viene saturata dagli scambi dati del tunnel (sono hdsl 8 mega)

Il cliente mi domanda che nel sito di ROUTER 2 venga data priorità alle comunicazioni verso il device 192.168.1.10 che si trova nel sito di ROUTER 1

In buona sostanza mi trovo nelle condizioni di dover impostare una priorità o un sistema che quando la linea si satura, mi consenta comunque di dare priorità al traffico verso il 192.168.1.10 raggungibile tramite il tunnel

Al momento le configurazioni sono davvero semplice.
Route statiche e fine. Nessuna regola particolare.
Mi potete dare qualche dritta su come poter configurare, possibilmente in modo semplice, la priorità come richiesto ? Grazie mille anticipatamente
User avatar
davide0522
Cisco fan
 
Posts: 30
Joined: Wed 31 Mar , 2010 4:22 pm

Re: QOS dentro un tunnel gre

Postby scolpi » Sat 20 May , 2017 4:46 pm

Hai due alternative a disposizione.
1) qos-preclassify
2) marcare il traffico che deve entrare nel tunnel con un valore di dscp sul quale baserai il metering del traffico

Nel primo caso, la config può essere questa:
Code: Select all
ip access-list extended CE1
 permit ip host 192.168.1.10 any

class-map match-all CL_CE1
 match access-group name CE1
policy-map PL_CE1
 class CL_CE1
  bandwidth 10
policy-map PL_SHAPE
 class class-default
  shape average 100000
   service-policy PL_CE1

!
interface Tunnel0
 ip address 1.1.1.1 255.255.255.252
 qos pre-classify
 tunnel source Ethernet1/3
 tunnel destination 99.99.99.98
!
!
interface Ethernet1/3
 ip address 88.88.88.89 255.255.255.252
 ip ospf network point-to-point
 ip ospf 1 area 0
 load-interval 30
 service-policy output PL_SHAPE
!


Per il secondo cambia nel modo seguente:
Code: Select all
ip access-list extended CE1
 permit ip host 192.168.1.10 any

class-map match-all CL_CE1
 match access-group name CE1

policy-map PL_MARK
 class CL_CE1
  set dscp cs5

class-map match-all CL_CS5
 match dscp cs5

policy-map PL_CE1
 class CL_CS5
  bandwidth 10


policy-map PL_SHAPE
 class class-default
  shape average 100000
   service-policy PL_CE1
nterface Ethernet1/3
 ip address 88.88.88.89 255.255.255.252
 ip ospf network point-to-point
 ip ospf 1 area 0
 load-interval 30
 service-policy output PL_SHAPE
!
interface Ethernet0/0
 ip address 192.168.1.1 255.255.255.0
 service-policy input PL_MARK

Last edited by scolpi on Mon 22 May , 2017 9:10 pm, edited 1 time in total.
CCNA Security,CCDP, CCNP R&S
scolpi
Network Emperor
 
Posts: 337
Joined: Sat 30 Oct , 2010 5:33 pm

Re: QOS dentro un tunnel gre

Postby davide0522 » Sun 21 May , 2017 8:28 am

Ciao, grazie per la risposta. Ho usato la prima strada, ma se do il comando

sh policy-map interface fa0

dopo aver generato traffico verso l'ip indicato, ottengo quanto segue. Mi sembra che non stia funzionando ? O mi sbaglio ?

PS: il router è un 1803 con c180x-adventerprisek9-mz.151-4.M7.bin , spero supporti la funzione.

FastEthernet0

Service-policy output: PL_SHAPE

Class-map: class-default (match-any)
8735 packets, 3706837 bytes
5 minute offered rate 76000 bps, drop rate 0 bps
Match: any
Queueing
queue limit 64 packets
(queue depth/total drops/no-buffer drops) 4/0/0
(pkts output/bytes output) 8737/3708813
shape (average) cir 100000, bc 400, be 400
target shape rate 100000

Service-policy : PL_CE1

Class-map: CL_CE1 (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group name CE1
Queueing
queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 0/0
bandwidth 10 kbps

Class-map: class-default (match-any)
8735 packets, 3706837 bytes
5 minute offered rate 76000 bps, drop rate 0 bps
Match: any

queue limit 64 packets
(queue depth/total drops/no-buffer drops) 3/0/0
(pkts output/bytes output) 8737/3708813





Qualcosa comunque succede..... I ping da router a router passano da 5 ms a oltre 1500........
User avatar
davide0522
Cisco fan
 
Posts: 30
Joined: Wed 31 Mar , 2010 4:22 pm

Re: QOS dentro un tunnel gre

Postby davide0522 » Sun 21 May , 2017 8:51 am

Ciao, scusami di nuovo, sto facendo qualche prova, e vedo qualcosa di diverso se imposto


Code: Select all
ip access-list extended CE1
 permit ip any host 192.168.1.10


anzichè

Code: Select all
ip access-list extended CE1
 permit ip host 192.168.1.10 any


Ha senso ? 192.168.1.10 è il server remoto rispetto al router su cui sto configurando.
User avatar
davide0522
Cisco fan
 
Posts: 30
Joined: Wed 31 Mar , 2010 4:22 pm

Re: QOS dentro un tunnel gre

Postby scolpi » Mon 22 May , 2017 9:09 pm

Code: Select all
ip access-list extended CE1
 permit ip any host 192.168.1.10


per le acl il primo è sempre la sorgente e il secondo la destinazione.

Quindi questa è ok
CCNA Security,CCDP, CCNP R&S
scolpi
Network Emperor
 
Posts: 337
Joined: Sat 30 Oct , 2010 5:33 pm


Return to Infrastrutture Cisco

Who is online

Users browsing this forum: No registered users and 6 guests