nat sub interfaccia vlan su interfaccia ip pubblico

Virtual private networks e affini

Moderators: Federico.Lagni, Wizard, tonycimo, MaiO, CiscoBoy

nat sub interfaccia vlan su interfaccia ip pubblico

Postby febelus » Sat 18 Oct , 2014 9:22 am

ciao a tutti,
con il mio router 1800 ho la necessità di gestire due vlan (1 e 20) per configurare un sistema wifi. ho configurato lo switch sotto al router configurando le porte dove è collegato il router e gli ap (che dovranno utilizzare sia la vlan 1 che la vlan 20) come porte trunk. Il mio router era configurato per gestire il mio pool di 8 ip pubblici con la fastethernet 0/0 configurata con il primo ip pubblico del pool e con un dhcp che assegna ip pubblici. Ho quindi aggiunto un subinterface ethernet 0/0.20 incapsulta dot1q su una vlan 20 e datogli un indirizzo ip interno 192.168.40.1 e creata una entry per un dhcp su questa sottorete. ho configurato la fastethernet 0/0 con nat outside e la fastethernet 0/0.20 con nat inside creato una acl per la sottorete 192.168.40.0/24 e un nat inside della acl in questione con overload su fastethernet 0.0 ma non funziona o meglio il traffico taggato vlan20 sulle porte dello switch viene correttamente riconosciuto e gli viene assegnato un ip della sottorete 192.168.40.0/24 ed è in grado di pingare sia l'interfaccia interna che esterna del router (192.168.40.1 e ip pubblico della fe0/0) ma non è in grado di uscire su internet. Qual'è il problema? questa è la mia config:
Code: Select all
Current configuration : 2586 bytes
!
version 12.4
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname ##############
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
logging buffered 64000
no logging console
enable secret 5 ####################
!
aaa new-model
!
!
!
!
aaa session-id common
clock timezone GMT+1 1
clock summer-time GMT+2 recurring
no ip source-route
!
!
ip dhcp excluded-address 82.85.162.1
ip dhcp excluded-address 192.168.40.1
!
ip dhcp pool LAN_Roma_Eletronica
   network 82.85.162.0 255.255.255.192
   default-router 82.85.162.1
   dns-server 213.205.36.70 213.205.32.70
   lease 0 0 15
ip dhcp pool vlan20
   network 192.168.40.0 255.255.255.0
   default-router 192.168.40.1
   dns-server 8.8.8.8 8.8.4.4
   lease 0 0 15
!
!
ip cef
no ip domain lookup
ip name-server 213.205.32.70
ip name-server 213.205.36.70
multilink bundle-name authenticated
!
!
username ######### password 7 #########
archive
 log config
  hidekeys
!
!
!
!
!
interface FastEthernet0/0
 ip address 82.85.162.1 255.255.255.192
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
 no keepalive
!
interface FastEthernet0/0.20
 encapsulation dot1Q 20
 ip address 192.168.40.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface Serial0/0/0
 bandwidth 2048
no ip address
 encapsulation frame-relay IETF
 no fair-queue
 frame-relay traffic-shaping
 hold-queue 4096 in
 hold-queue 4096 out
!
interface Serial0/0/0.100 point-to-point
 bandwidth 1600
 no cdp enable
 frame-relay interface-dlci 100 ppp Virtual-Template1
  class FR-1600
!
interface Virtual-Template1
 bandwidth 1600
 ip address negotiated
 ip tcp adjust-mss 1410
 keepalive 5
 ppp chap hostname #################
 ppp chap password 7 ################
 ppp pap sent-username ############## password 7 ##############
 ppp ipcp route default
!
ip forward-protocol nd
!
!
no ip http server
ip nat inside source list 110 interface FastEthernet0/0 overload
!
!
map-class frame-relay FR-1600
 frame-relay cir 1600000
 frame-relay bc 200000
 frame-relay mincir 1000000

access-list 1 permit 192.168.40.0 0.0.0.255
access-list 110 permit ip 192.168.40.0 0.0.0.255 any
!
!
control-plane
!
!
line con 0
 session-timeout 60
 exec-timeout 60 0
 privilege level 15
line aux 0
 privilege level 15
line vty 0 4
 session-timeout 60
 access-class 10 in
 exec-timeout 60 0
!
scheduler allocate 20000 1000
febelus
n00b
 
Posts: 17
Joined: Tue 18 Oct , 2005 10:27 pm

Return to VPN

Who is online

Users browsing this forum: No registered users and 1 guest